Archive

Posts Tagged ‘Vault’

cannot checkin *.doc / *.xls into vault 2013

November 28th, 2012 No comments

we came across this problem.
We use netapp as filestore and can checkin CAD Data as well as txt documents, but office files (doc, xls..) were not possible to checkin.
Error message was this:
27-11-2012 13:45:23 *******************************************************************
Error: Soap Exception ( mesg-id = 634896207239552713 )
Exception: BadResourceRelativePath [111]
Stacktrace:
Server stack trace:
at Connectivity.Core.DataAccess.ResourceStore.StoreResource(KnowledgeVault context, Stream sourceResourceStream, Resource resource, DateTime lastWriteTime)
at Connectivity.Document.BusinessLogic.FileBL.a(Int64 A_0, String A_1, Nullable`1 A_2, DateTime A_3, Int32 A_4, Int64 A_5, Boolean A_6, FileAssociationParam[] A_7, BOM A_8, String A_9, FileClassification A_10, Boolean A_11, Stream A_12, File A_13, Boolean A_14, Boolean A_15, Int64 A_16)
at Connectivity.Document.BusinessLogic.FileBL.CheckinFile(Int64 fileMasterId, String comment, Boolean keepCheckedOut, Int64 checkinUser, Nullable`1 checkinDate, Nullable`1 lastWrite, FileAssociationParam[] associations, BOM bom, Boolean copyBom, String newFilename, FileClassification fileClassification, Boolean hidden, Stream fileStream, CheckinOptions options)
at Connectivity.Document.BusinessLogic.FileBL.CheckinFile(Int64 fileMasterId, String comment, Boolean keepCheckedOut, DateTime lastWrite, FileAssociationParam[] associations, BOM bom, Boolean copyBom, String newFilename, FileClassification fileClassification, Boolean hidden, Stream fileStream)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Connectivity.Document.Services.FileService.CheckinFile(Int64 fileMasterId, String comment, Boolean keepCheckedOut, DateTime lastWrite, FileAssociationParam[] associations, BOM bom, Boolean copyBom, String newFilename, FileClassification fileClassification, Boolean hidden, Stream fileStream)
at Connectivity.Web.Services.v17.DocumentService.CheckinFile(Int64 fileMasterId, String comment, Boolean keepCheckedOut, DateTime lastWrite, FileAssociationParam[] associations, BOM bom, Boolean copyBom, String newFileName, FileClassification fileClassification, Boolean hidden, ByteArray`1 fileContents)

Exception(Inner): Access to the path ‘\\netapp\VAULT\000\000\000\000\000\000\10\10_20000000085_4.doc’ is denied.
Stacktrace(Inner): at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
at Connectivity.Core.DataAccess.ResourceStore.StoreResource(KnowledgeVault context, Stream sourceResourceStream, Resource resource, DateTime lastWriteTime)

I tried then to open or copy this file manually. No chance.
It told me:
“you require permission from “impersonation service account” to make changes to this file”

After some checking of permissions, playing around with them as well as restarting the server, I came to the decision it has to be something with the netapp.
When I moved the filestore with ADMS console to the local C:\drive everything was working.

So I checked on the netapp, but did not find the corresponding setting and asked the storage people.
It turns out storage people are luckily also the antivirus people and mcafee vscan was activated, but did not have a scanserver configured.
Meaning mcafee wanted to scan the office files for viruses, but did not had a scan entity behind to fulfill the operation.
so it locked the file and did not set the permissions properly back so the file could be used.

After configuring this part correctly on the netapp everything worked like a charm.

this is how it is configured on the netapp:

netapp001> vscan
Virus scanning is enabled.
Virus scanners(IP and Name) P/S Connect time (dd:hh:mm) Reqs Fails Curr. Reqs.
——————————————————————————– ———–
IP \\SRV1 Pri 00:03:11 1 0 0
IP \\SRV2 Pri 00:03:10 1 0 0

List of extensions to scan:
001,002,386,3GR,??_,ACE,ACM,ADE,ADP,ADT,AP?,ARC,ARJ,ASA,ASD,ASP,AX?,B64,BA?,BIN ,BMP,BO?,BZ?,CAB,CC?,CDR,CDX,CEO,CGI,CHM,CL?,CMD,CNV,CO?,CPL,CPT,CPY,CRT,CSC,CSS ,CSV,D?B,DAT,DEV,DIF,DL?,DO?,DOC,DOT,DQY,DRV,EE?,EFV,EML,EX?,EXE,FDF,FMT,FO?,FPH ,FPW,GF?,GIM,GIX,GMS,GNA,GW?,GWI,GZ?,HDI,HHT,HLP,HT?,HWD,ICE,ICS,IM?,IN?,IQY,ISP ,ITS,JAR,JP?,JS?,LGP,LIB,LNK,LWP,LZH,M3U,MB0,MB1,MB2,MBR,MD?,MHT,MOD,MPD,MPP,MPT ,MRC,MS?,MSG,MSO,NAP,NEW,NWS,OB?,OC?,OFT,OL?,OLE,OTM,OV?,PCD,PCI,PD?,PDF,PF?,PHP ,PI?,PLG,POT,PP?,PPZ,PRC,PWZ,QLB,QPW,QQY,QTC,RAR,REG,RMF,RQY,RTF,SCR,SCT,SH?,SIS ,SKV,SLK,SMM,SPL,SRF,SWF,SYS,TAR,TAZ,TBZ,TD0,TFT,TGZ,TLB,TSP,UNP,URL,UUU,VB?,VBS ,VS?,VVV,VWP,VXD,WBK,WIZ,WMV,WP?,WRI,WRL,WRZ,WS?,X32,XL?,XML,XRF,XSL,XTP,XX?,Z0M ,Z??,ZI?,ZIP,ZL?,ZZZ

List of extensions not to scan:
Extensions-not-to-scan list is empty.

Number of files scanned: 2
Number of scan failures: 0
Number of throttled requests: 0
netapp001>

Categories: Allgemein Tags: , , ,

ADMS could not find Data Management Services on 127.0.0.1 – Vault Pro 2013

November 22nd, 2012 1 comment

You get this error when opening from ADMS Console Tools/Administration?
It is a problem with the impersonation account within ASP.

We see this problem from time to time. Today my problem was solved, by opening http://Localhost/AutodeskDM/Services/SecurityService.asmx (as advised in here) where I saw then the local user account created by the Vault installer and an error message from ASP.net.

So go in the web.conf in: C:\Program Files\Autodesk\ADMS Professional 2013\Server\Web\Services and search for “impersonate”
you will find there a line like that:
(password not really sure 😉

you have to adjust this line to this, where you fill in your service account (which has also rights on your filestore):

After that restart IIS and you are done.

Root cause for this issue is the inability of the vault installer to resolve Active Directory accounts and every account you fill in during setup will be created freshly as local account in the machine.

Categories: Allgemein, Work Tags: ,

Referenced Vault does not exist – Vault Professional 2012

November 15th, 2012 1 comment

I got this error when trying to disable Workgroup replication for a specific Vault to the subscriber.

Problem was, that the vault – which was concerned – was disabled at the publisher.
I re enabled it on the publisher and disabled sucessfully the replication afterwards.

Categories: Allgemein Tags: , ,

Vault Beta Program Kampai

November 6th, 2012 No comments

https://beta.autodesk.com to sign up for 2014 beta!

Categories: Allgemein, Work Tags: , ,

as I recognized

October 16th, 2012 No comments

lots of people came across from different countries to this homepage already, please feel free to ask questions or comment on the posts
thanks

Theme by NeoEase. Valid XHTML 1.1 and CSS 3.